Wednesday, November 21, 2012

Help with patching (v3.00)

This post has been retired. Please visit the Version 3.01 post.

207 comments:

  1. This comment has been removed by the author.

    ReplyDelete
    Replies
    1. Oh, sure, take the first post, THEN DELETE IT. *grumble grumble*

      Delete
  2. I'm having problems getting the rom to patch, when I drag it over to the patch does nothing. The only rom I found (so far) is dsi enhanced, would that change anything? I'm running on a macbook and the emulator I'm using is desume. Help?

    ReplyDelete
    Replies
    1. >I'm running on a macbook

      That explains it all.

      The Drag rom here file is in .bat format which is a MS-DOS Batch file.

      We need to make a mac version.

      Delete
    2. Oh, are you guys planning on doing that or should I just find a way to bootcamp my computer?

      Delete
    3. No, we'll be making a Mac version, don't worry.

      Delete
    4. Thanks, do you guys have a estimation of when? Just so I can stop refreshing every 10 mins lol

      Delete
    5. Don't expect it within the next 10 min or so... though I believe it should be out today. (I dunno exactly since I don't have a mac, but there is someone on our team who is working to make sure it works on a mac).

      Delete
    6. It's actually up but I want to confirm with Vincent that it's okay to share it

      Delete
  3. It says I am missing a program called MSVCR100.dll from my computer... Anyway I can find it?

    ReplyDelete
    Replies
    1. You are using WinXp or a 32 bit system. Thus you need to download this xdelta:

      http://www.mediafire.com/?ru143n54ljn1m8p

      (I uploaded that file from my winxp)

      Be sure to replace the xdelta provided and rename the file to xdelta

      Delete
    2. I downloaded the xdelta, but I'm still having problems. Come to think of it, it's been that way with xdelta in general since my computer was updated...I keep getting 'error'.

      Delete
    3. Oh, and one more thing..I just downloaded the patch and desume. My computer's operating system is windowsvista. That's windows xp right? Sorry for sounding like a total idiot...

      Delete
    4. I had the same problem and the xdelta Illumio linked worked perfectly. Thanks!

      Delete
    5. I had the same problem, and the proveded xdelta did NOT work. When I try to patch with the xp xdelta, it simply says the name of my ROM and "Access is denied". I've made sure the ROM is 128 mb. Its name is "5096 - Fire Emblem - Shin Monshou no Nazo Hikari to Kage no Eiyuu (v01)(DSi Enhanced) (J)(SUXX)" Is that right?

      The original provided xdelta gives the same dll error as above.

      I am using Windows 7.

      Please help with this. It's my grandfather's funeral today and my family is stressing the fuck out. They really don't meed my screaming at my computer screen right now.

      Delete
    6. Never mind. Downloaded the UI version of xdelta and it worked. Hope this helps anyone else with my problem.

      Delete
    7. I have the same problem. How did you fix it with the UI verson of xdelta?

      Delete
  4. First thanks for the patch but its not working with my flashcard

    ReplyDelete
    Replies
    1. Which flashcard are you using?

      Delete
    2. Also, did the original Japanese ROM even work on your flashcard?

      Delete
    3. Yes the original did work and the patched worked in DesmuMe or at least it booted in DesmuMe

      Delete
  5. I'm having the same problem as the above poster. Here's the actual error.
    http://i47.tinypic.com/r86xl2.jpg

    ReplyDelete
    Replies
    1. You are using WinXp or a 32 bit system. Thus you need to download this xdelta:

      http://www.mediafire.com/?ru143n54ljn1m8p

      (I uploaded that file from my winxp)

      Be sure to replace the xdelta provided and rename the file to xdelta

      (I just reposted)

      Delete
    2. You can ignore this, since you've answered the other post. Thank you.

      Delete
    3. I use Windows 7 64-bit and still got the same problem as the image above. Will downloading this file solve my problem?

      Delete
  6. Illuminio I had the same problem!Your xdelta file worked like a charm!THANK YOU!!!

    ReplyDelete
  7. An updated version that should have some remedies for this in the Instructions is coming soon. Please be patient. :)

    ReplyDelete
  8. Thank you so much for releasing it today, I was about to do on vacation for Thanksgiving and would of had nothing to do. So thanks again I have been here from the begining and am so happy to se it done.

    ReplyDelete
  9. Until Vincent uploads some instructions for Mac users and stuff, here's the download that fixes one minor issue in patching and gives links to MultiPatch for Mac users and xdelta UI for people having a hard time with the drag-and-drop method.

    http://www.feshrine.net/fe12/FE12_v3.00.zip

    :)

    ReplyDelete
    Replies
    1. I don't know if we crashed it, but the website given for http://projects.sappharad.com/tools/multipatch.html won't open....

      Delete
    2. it works for me but google brings up another link:

      http://www.romhacking.net/utilities/746/

      Delete
    3. I got it open, thanks. Except now it says the FE12_v3_00.Pat isn't a supported file

      Delete
    4. hmm, I don't have a mac, so I can't test this too well... um, try renaming the .pat file to whatever extension it requires. Sadly, I can't really check... *tries to do something*

      Delete
    5. okay, I just read the README and it says that the proper extension is .DAT; you'll have to rename the patch file from "FE12_v3_00.PAT" to "FE12_v3_00.DAT" for it to work. XP

      Delete
    6. IT'S ALIVE!!! Renaming it to .delta totally works. Thanks for all your hard work

      Delete
    7. It works? Thank goodness. I'm updating the patch to reflect it. My bad, it slipped my mind that MultiPatch would give these silly issues. -_-

      Delete
  10. Thank you all for your hard work and effort.

    ReplyDelete
  11. What program do I need to run this on a Windows 7?

    ReplyDelete
    Replies
    1. To be able to play the rom you either need DeSmuMe or No$GBA.


      I'm assuming that's what you are talking about. If not, them please clarify.

      Delete
    2. Any idea where I can get them? I'm new to downloading games from sites, so I have no apps for it

      Delete
    3. >I have no apps for it
      I don't even...

      Look under the downloads tab of this website again...

      Delete
    4. You can get them from their official sites www.nogba.com and desmume.com

      Delete
    5. Unless you are asking for us to give you a link as to where you can download the ROM, then no, we cannot provide that to you.

      Delete
  12. Whenever I try to run it, it says: "Unable to load data. Please turn off the power and try again." I keep trying over and over, but it does it every time

    ReplyDelete
    Replies
    1. Please include your emulator or flashcart of choice and operating system in all bug reports. Thanks.

      Delete
    2. Oh wait. I have the 84 kb patch. How do I get the full one?

      Delete
    3. I've been using a the full 128MB from the start. I applied the patch, and then tested in DeSmuME, and all I get is a black screen. I got the error that says "Unable to load data. Please turn off the power and try again" in No$GBA

      Delete
    4. Whenever I try to patch it, it becomes significantly smaller

      Delete
    5. it becoming smaller is something that doesn't affect the game but is fixed in the newest version. If you're using no$GBA then the issue is probably save type; I'd try playing around and changing it (assuming you can't get Desmume to work, since Desmume is much better IMO).

      Delete
    6. That's supposed to happen. As long as you started out with 128MB it's fine.

      Delete
    7. It's working now!!!! :DDDDDD THANK YOU SO MUCH!!!!!!

      Delete
  13. Thanks guys the Fire Emblem community owe a great deal to you guys for putting all that time and effort in this patch. My most sincere thanks for you all

    ReplyDelete
  14. Oh man, this is amazing. Fantastic job done by you guys. I had a terrible day at school, so this will cheer me up. Thank you Heroes of Shadow! :D

    ReplyDelete
    Replies
    1. And I've just posted on the wrong blog. Sorry, disregard my message earlier post.

      Delete
  15. the link to the program to patch on a mac doesnt work.

    ReplyDelete
  16. works on supercard dstwo testing acekard 2i

    ReplyDelete
    Replies
    1. We already know it works on those flashcarts (I tested the AceKard2i myself during the beta)

      Delete
    2. Indeed, we tested as many flashcarts as we could [s]those two[/s]amongst other things

      [s]don't remind me of the bug where the game wouldn't work on flashcarts T_T[/s]

      Delete
  17. Hi,
    I manage to make the patched rom working in Desmune emulator, but i'm unable to play in my R4 SDHC flashcart with YSMenu. I get an errorcode -4, and i'm using the latest upgrade. Anyone with this flashcart did it?

    ReplyDelete
    Replies
    1. I doubt the homebrew is making much of a difference here, but we didn't get to try the flashcart you mentioned... Does it have autopatch? There's a very small chance that there's Anti-Piracy still in the thing (though I doubt it)... and you may as well try TTMenu...

      no wait, a quick google search says:

      "Error Code -4:
      Means: The game you're trying to play is either DSi enhanced or has AP
      How To Fix: wait for a fix in that game in the latest unnoficial dstt firmware and rebuild ysmenu using that"

      FE12 is DSi enhanced; try upgrading your firmware or using a different menu. If that doesn't work, I'm afraid that your flashcart is a bit outdated and that you're out of luck.

      Delete
    2. Hi Blazer, thanks for your assistance.

      Dunno if it has AP or something; the thing is that I can load and play with the clean rom, but after patching it won't start.

      I'll try some more things; if I manage to make it work then I'll explain how.

      Delete
    3. I see... Sadly, I don't have the flashcart, so I can't really test what's wrong, and I really don't have any other ideas. I'm sorry. :(

      Delete
    4. I have the same problem, since I'm using an R4 Revolution (R4 clone) with YSMenu. To get the game to work, you'll have to update your DAT files for YSMenu, specifically the extinfo.dat and infolib.dat, but there might be more. At the moment, you'll have to wait for someone to update the Dat files (Most likely RetroGameFan will do it). We'll have to wait a bit longer, but that's it I think.

      Delete
    5. That seems to be the case, we'll have to wait. I'm playing in Desmune, meanwhile, and the translation it's pretty awesome.

      Let's wait for RetroGamer update.

      Delete
    6. I am waiting as well (DSTT with YSMenu). Clean JPN rom works, but not the patched version.

      Thanks for completing the translation, I look forward to playing it.

      Delete
    7. You just have to edit the infolib.dat in your YSMenu/TTMenu folder using the program TTDT (you find it inside RGF's YSMenu updates).

      In the specific, just open the file and search for the tag "VI2J" (there should be 2), then duplicate (copy, then paste) one of them and rename it into "VI2J 1DFB4EB9". This remove the -4 error and let you load the ROM.

      Delete
    8. Thank you very much. This worked for me (DSTT w/ YSMenu).

      Delete
    9. I had the same problem on my DSTT with YSMenu getting Errcode-4 and tried Ogogin's method- now the patched game loads farther but then gives me an errcode-81. Is there anything else that can be done?

      Delete
    10. I haven't had a chance to play yet after I did the infolib.dat addition, I can only confirm that it loaded to the main menu. I am on Retrogamefan v6.95.

      Delete
    11. Error Code -81 is a SD card problem, not directly related to the firmware. It is normally fixed by formatting the SD card and then re-installing everything.

      By the way, RGF released a new firmware update that fix Fire Emblem 12 patched USA by default; it also include cwcheat codes in case you have AP issue (possibile on VERY OLD R4 models). In that case just activate the AP fix code and every possible problem is solved, but the -81 error is not caused by AP so you still need to format your memory stick ^_^

      Delete
  18. THANKS A LOT GUYS FOR THE PATCH AWESOME JOB.

    ReplyDelete
  19. So I am using a Mac and attempting to patch my game through Multipatch. I first tried patching the ROM with the .PAT patch provided, but it said not supported, so I created a patch to make it .UPS (I think I did that part right, not positive.) I then tried to patch it, and it says "Input file (the file you're applying the patch to) size and/or CRC32 invalid. This means you picked the wrong file." I figured this meant download a new ROM, which I did and the same issue occurred. I tried renaming the patch .DAT, but then it didn't appear during the browsing. What should I do?

    The actual new rom appears, but it crashes in NO$GBA and in DESMUME, it says An emulation error occurred. What should I do?? Please help :(

    ReplyDelete
    Replies
    1. thanks for your detailed report; the patching process didn't work so it doesn't work in Desmume. Try this version, first:

      http://www.feshrine.net/fe12/FE12_v3.00.zip

      You'll have to use MultiPatch, as mentioned. It -should- recognize the file as an xdelta patch and patch correctly. If it doesn't, please let me know ASAP.

      Delete
    2. OK so it all worked and such, I will try out saving and that soon and let you know. However, I am currently having sound issues. The sound was crackly until I left the title screen, but now the sound is almost always muted, and just sometimes fades in. This is on NO$GBA, as the other one did not work. Help?

      Delete
    3. Sorry to double post, but I lived with my non-existant sound until I finished making my MU, but when I started the Prologue, the game freezed, and thus I quit the emulator, only to find what I had just saved was erased...I am so confused :/

      Delete
    4. TheEnd mentioned earlier that Desmume's sound needs to be set to "Cosine" and "Syncronous". I don't know how that translates to No$GBA, but you might try poking around the sound options for something to that effect.

      Delete
  20. Already enjoying this, thanks you guys

    ReplyDelete
  21. Guys, this is the place for patching help; please try to keep appreciative posts (as much as we appreciate them) in the main thread. Thanks! :)

    ReplyDelete
  22. I realized It'd be easier for you guys to see me if I posted below here. I have the same MSVCR100.dll issue as above. My operational system is Windows 7 64-bit.

    ReplyDelete
    Replies
    1. try using the same solution or use xdelta UI (download link included in the Instructions)

      Delete
    2. I already had xdeltaUI in my computer, actually. Which archive is actually the patch to apply, as I see nothing with the .xdelta extension?

      Delete
    3. If you download and extract the ZIP, there's a .dat file: http://www.feshrine.net/fe12/FE12_v3_00.zip

      that file is the patch. for most Windows systems, just drag and drop. For others, either follow the given instructions:

      "Windows XP users *may* have issues patching. If this occurs, go to the xdelta official site and download xdelta for Windows XP. Then replace the xdelta we've provided with the one you downloaded."

      and if you have a mac, do this:

      "If you want to patch on a Mac, please use MultiPatch: http://www.romhacking.net/utilities/746/ - note that the patch file is the "FE12_v3_00.dat" file and that you must specify the location of both the original ROM and the output ROM."

      Delete
    4. I downloaded illumio's file, everything worked quite nicely, I think. Though the file size apparently didn't change at all.

      Delete
    5. And as I've said above, I use windows 7 64-bit.

      Delete
    6. Thank you for the help. I guess patching with xdeltaUI also worked.

      Delete
    7. good, glad to hear. and I fixed the file size changing already

      Delete
  23. Ok. I have windows xp and have just downloaded the new xdelta program and such, but as soon as I try and patch I get this message from system command:

    xdelta3: source file too short: XD3_INTERNAL.

    The xdelta patching utility was unable to make the patch. Make sure to use the orginal ROM and extract all of the patch files to the same folder before running this.

    ...

    I don't know if I've messed a step or what. Sorry to be a bother, but what should I do? Thanks so much for your time.

    ReplyDelete
    Replies
    1. try the first solution for windows XP users; make sure you're extracting the files and everything too.

      Delete
    2. AFAIK this is because you're using a prepatched ROM. You need to find a clean ROM, which is 128 MB. Prepatched ROMs are about 84 MB.

      Delete
    3. ^given that it says "source file too short" that's definitely a possibility. make sure you extracted not only the patch but the ROM, too

      Delete
    4. The Rom? I didn't see that? All I saw was the FE 12 zip folder...I extracted all of the files, or at least I thought so...

      Delete
    5. hm? I'm a bit confused now... the ROM isn't included in the download, only the patch. You have to obtain a ROM (we can't help you find a "Fire Emblem 12 (J) ROM" on Google, you have to do it yourself) and extract that, download the patch, extract that too, and then download the xdelta program, replace the given one with the windows XP one, and then drag the .nds file onto the patcher.

      Here's the patch download: http://www.feshrine.net/fe12/FE12_v3.00.zip

      the instructions give a link to the xdelta file for Windows XP

      Delete
    6. Blazer meant the rom of FE12 that you downloaded. The rom isn't included in the patch zip, and most roms downloaded off the internet are in a rar or zip format. So check the downloaded rom of FE 12 you have and make sure it's 128 MB, and in NDS file format.

      Delete
    7. Ah...I just realized what I did wrong. For whatever reason I thought desmume, which I already downloaded, was the rom. Sorry about that. I'm currently downloading the fe 12 rom now though. Hopefully it works.

      Delete
  24. Hello there
    thanks for the patch and i have as well the problem with the MSVCR100.dll and as well win7 and 64 bit version

    ReplyDelete
    Replies
    1. try installing MSVCR100.dll - http://www.dll-files.com/dffsetup-msvcr100.exe

      please let me know of the result

      Delete
    2. Just download the file I mentioned earlier and rename it to xdelta and it will work.

      Delete
    3. Blazer thanks , IllumioOOO has helped with the redownload of the xdelta
      and now it has functioned^^

      Delete
  25. An alternate download link for xdelta, provided by Illumio, is here: http://www.mediafire.com/?ru143n54ljn1m8p

    Please read the given instructions before patching and reporting problems. Thanks, good luck, and enjoy!

    ReplyDelete
  26. Okay, my live patching help is now over. If you need additional help be sure to make a new comment with as much information as you can give and one of the team members will get to you as soon as possible. Thanks~

    ReplyDelete
    Replies
    1. Oh and ATM the latest version is here: http://www.feshrine.net/fe12/FE12_v3.00.zip

      Delete
    2. hey but you helped as well , dont be done , thank you as well for the tip ^^

      Delete
  27. for people with Mac using Multipatch:

    rename the .pat file to .xdelta

    multipatch will recognize it then

    ReplyDelete
    Replies
    1. the latest patch already renames it to .delta for you

      Delete
  28. I'm running Windows 7 64-bit, and when I drag the clean rom onto the "DRAG CLEAN ROM HERE", it says "XD3_INVALID_INPUT". I've tried it with Illumio's xdelta link, but it still doesn't work.

    ReplyDelete
    Replies
    1. your ROM is bad. Make sure it's extracted and everything and that it's clean and doesn't have some other patching on it like Anti-Piracy patching or something.

      Delete
  29. I'm using an Acekard 2, and while the patch does work, there is considerable lag when loading the Title Screen. I've been able to bypass it by pressing the Touch screen as soon as it pops up, but if I miss that window the game becomes unplayable.
    Is this a problem with my flashcart?

    ReplyDelete
    Replies
    1. Sounds like it as I've never heard of any issue anything like that.

      Delete
    2. I'm using Acekard 2 as well, and everything's good so far. Beat the 1st 3 prologue chapters and even connected to Wifi.

      Did you try updating your card's firmware to the most recent version?

      Delete
  30. is the xdelta thing required? or should i wait until it is fixed?

    ReplyDelete
    Replies
    1. I'm pretty sure everything is "fixed" [s]though to be fair it all worked from the beginning, we just didn't make it easy enough[/s]

      Delete
    2. Well, i guess i may have to download the xdelta file, although my friend keeps whining saying," xdelta is a unknown file, what if it isn't safe? "-_-'" Well, i'm sure there aren't any problems with that file, right?

      Delete
    3. Never mind, it's downloaded successfully! Thanks

      Delete
    4. sorry, some computers or browsers give warnings to .exe files because they are applications so hypothetically speaking it'd be more likely to be a virus than like, a picture file (.png)

      it's safe though

      Delete
  31. OK so it all worked and such, I will try out saving and that soon and let you know. However, I am currently having sound issues. The sound was crackly until I left the title screen, but now the sound is almost always muted, and just sometimes fades in. This is on NO$GBA, as the other one did not work. And once I gave up on this, I moved on with no sound, and after I saved after I created my MU, the game froze and I had to quit where I lost my file...Help :(

    (This is the guy from before with the detailed report, sorry to be abnoxious X_X)

    ReplyDelete
    Replies
    1. Have you tried using DeSmuME? It's more stable, but consumes more resources and might be slower if your PC is too slow/old.

      Otherwise, what version of NO$GBA are you using? I have 2.6 running fine with it, minus the crackly intro music.

      Delete
    2. I am using a Macbook Pro, DeSmuME doesn't seem to work for me. NO$GBA worked intially, but then had the issues I just mentioned. Its the newest version though

      Delete
    3. I have to disappear now, but does the original Japanese version work?

      Delete
    4. Unpatched japanese ROM runs fine.

      Delete
    5. The Japanese one doesn't work as well, I think its the emulator. I'm so confused on how to fix it though :/

      Delete
    6. For DeSmuME, try this link: http://sourceforge.net/projects/desmume/files/desmume/0.9.8/desmume-0.9.8-mac.dmg/download
      No$GBA seems to lack the more complicated sound options DeSmuME has.

      Delete
    7. Didn't work, says emulation crashed. Only No$GBA loads it, but it has the respective issue discussed before.

      Delete
  32. It doesn't seem to work on R4i Gold. I get the "load rom errorcode=4". I've got the latest firmware update and all, but no.

    ReplyDelete
    Replies
    1. IIRC I looked up the code earlier and it said something to the effect of "update your firmware or you're screwed because the game is DSi enhanced" (which it is) but try updating the menu that you use to load the ROM if possible and test the original game as well. Sadly I don't really have an R4 so I can't do much to try and fix the problem except give you generic solutions and tell you to google things... XP

      Delete
    2. I just did both and no luck... T_T

      Delete
    3. OK so I put a patched version of the game on my G6 Real DS Flashcart, which when selected, goes to an eternal black screen. Any suggestions?

      Delete
  33. Didnt mean to put this as a reply soo...

    I put a patched version of the game on my G6 Real DS Flashcart, which when selected, goes to an eternal black screen. Any suggestions?

    ReplyDelete
  34. Pardon my nubness, But is it name sensitive or something?

    Ive been fiddling with the files for a while & still can't get it to work. :c

    No matter what I drag, it still seems to give me the same file back (There is no "_Patched" file after the ~patching process.)

    I know it's the 128 file. But it had a crazy long name /I've even tried the names mentioned on the help file/ and everything..
    --
    Can't it be patched manually? /A le Sword of Seals?

    ------
    -Windows Vista - R4 FlashCart/wood

    ReplyDelete
    Replies
    1. Nevermind! ^^

      I used an administrator account/ -it gave me a dll error, -downloaded the thingy - Then another error telling me to make sure I was using the "original" copy.

      -I just renamed the file name after what BigKlingy posted (w/out the dsi enhanced part)

      & That seemed to do the trick? o_O

      Delete
    2. renaming shouldn't do anything, so I find that weird

      but you can use the UI xdelta to "manually patch it" (though you seemed to have fixed it, so eh)

      Delete
    3. I'm so sure that's what did it, -only thing I messed around with when it finally worked /which took several tries/

      Thanks again though. =)

      Delete
  35. I have no idea how to patch this. I have a mac and i use desmume. Can someone help me please?? Im desperate to play this game!!!

    ReplyDelete
    Replies
    1. There are instructions in the download.

      Delete
    2. so what do i need to put in where on multi patch?

      Delete
    3. better yet, how do i use multi patch??

      Delete
    4. For Macs:
      (1) download muiltpatch from http://www.romhacking.net/utilities/746/
      (2) Run muiltpatch (just read the instructions on the screen. Although I believe the order is patch, rom, location of where you want the new rom to go)
      (3) note: If the patch ext is .pat, you need to rename it to .delta for it to work.
      (4) The new rom should be were you selected, just load it into your rom
      (5) Play

      Delete
    5. the last option is save file as, and it is giving me a browse option. what do i select to put there?

      Delete
    6. got it. nevermind. Thanks soo much

      Delete
    7. OMG do you really not know how to download a file?!?

      Delete
  36. I'm using TTDS, YSmenu 6.95, the latest update. The patch ran correctly, making it 128 MB. And it was called what it was supposed to be. However, I error code 4, which means my menu is out of date, however it is the newest one.

    What do I do?

    ReplyDelete
    Replies
    1. There's a new update for YSMenu just today I think. Scroll down near or at the bottom of this blog to find a post with a link to Romulation forums with the update. Hope it goes well, and if it works, have fun :D

      Delete
  37. ive got it working!!! thanks for all of your hard work guys!

    ReplyDelete
  38. I can't get it to patch the file, I keep getting "The program can't start because MSVCR100.dll is missing from your computer."

    ReplyDelete
    Replies
    1. that's just one file
      google and download
      then put the .dll file into the same folder as the dropromhere and it should be able to patch

      Delete
    2. You can do what anon said or download a different xdelta from here:

      http://www.mediafire.com/?ru143n54ljn1m8p

      Also this question has been answered a lot. So, this isn't just directed to you, please read everything before posting the same question.

      Delete
  39. oooh! Thanks, very Thanks!!! I'm fan de Fire Emblem!!

    ReplyDelete
  40. Does anyone have it working on a flash cart?

    ReplyDelete
  41. First time commenter and long time follower.
    Im really happy that you guys could take your free time to make this translation happen.
    Thank you very much!!

    ReplyDelete
  42. Thanks so much for this guys, I'm loving the patch

    ReplyDelete
  43. not working on r4i 1.4.1 Clone using TTmenu/YSmenu V6.95

    ReplyDelete
    Replies
    1. check this link:

      http://forum.romulation.net/index.php?topic=43121.3150

      Delete
  44. Do you will make a new project for DS ?

    ReplyDelete
  45. doesn't works on no$gba..

    ReplyDelete
    Replies
    1. Really? I use it too and it works fine for me.

      Delete
  46. Way to go, guys! Thank you so much!

    ReplyDelete
  47. There's an update to ttmenu e ysmenu http://forum.romulation.net/index.php?topic=43121.3150

    ReplyDelete
    Replies
    1. thanks so much for sharing this, I don't really follow it or know how it works but now if anyone says they use TTmenu or Ysmenu I can link them to this

      Delete
    2. Indeed. Anyone who has a r4 sdhc or any type of clone need to use TTMenu through a ds file. Thanks for the help Blazer, and thank you very much for whoever posted that link! I can finally play~

      Delete
  48. thanks for all your hard work!! now, its fe12 time. XD

    ReplyDelete
  49. YAY! Happy times! Thank you for doing this, 2 thumbs up!

    ReplyDelete
  50. Thanks guys, great job ! :D

    ReplyDelete
  51. I'm sorry if I sound completely incompetent, but when I try to drag my ROM on to the .bat, well...it just simply won't. I'm crossed out of doing so. I'm on Windows Vista, I should be the administrator, and I'm completely hopeless when it comes to technology >__<. Any advice?

    ReplyDelete
    Replies
    1. Nevermind. I need to keep reminding myself that extracting everything will solve all of my problems. Outside of some sketchy audio quality during the title screen on DeSmuME, it works perfectly. Thank you so much!

      Delete
    2. Config>Sound Settings
      Switch Interpolation to Cosine and set the the Synchronization Mode to Synchronous, and even the title screen audio should be fixed.
      TheEnd posted that earlier. ^_^

      Delete
  52. I patched the game successfully, but when I tried putting it on my r4 card and play on my DS, I only get a white screen. What do? :/

    ReplyDelete
    Replies
    1. So... Do I need a DSi to play this? :/

      Delete
    2. Had the same problem. Hoping to find a solution as well :(

      Delete
    3. A lot of people seem to be having trouble with r4s. The two responses seem to be "wait for an update" or "edit the .dat files." I don't even have a flashcart yet, so I have no idea what that means, but an Anonymous posted this link above:
      http://forum.romulation.net/index.php?topic=43121.3150
      which is apparently an update to the software ("ttmenu and ysmenu") that does it for you. If that doesn't work, check Ogogin's post above and the Anonymous three posts above him. Sounds like they know how to do it manually.

      Delete
    4. I tried this, both updating the .dat with the new list and manually. I got it loading with TTmenu (got past error 4) but again, just blank screen :/

      Delete
    5. Anonymous mentioned editing two files, extinfo.dat and infolib.dat. Try editing both? Sorry, I've got no clue. I'm just repeating what I read earlier.

      Delete
  53. Absolutely amazing work! This was definitely worth the wait. Thank you very much!
    ~ Isaac55

    ReplyDelete
  54. Beautifully done, def an amazingly crafted translation, and for those who don't understand the importance of a good translation...
    http://www.youtube.com/watch?v=i3Xbtu8Ahek
    I present to you the spoony bard!

    Anyway, I'll miss our lovely fan base here, is there a general site/s for you guys so I can follow any future projects?

    Anyway off to finish the game by Monday

    <3 Always

    ReplyDelete
  55. I have a question about the DLC Bonus Content. I'm not quite understanding exactly the instructions. I've renamed the appropriate file for the No$gba, but when I try to add it in the 'Battery' folder, it asks me if I want to replace the original translated patched file. Am I supposed to replace it or...
    Any help on this would be greatly appreciated.

    ReplyDelete
    Replies
    1. In the "Bonus Content" folder, there's a save "For NO$GBA.sav". The patched rom can be anywhere.
      Let's say your patched rom is named "FE12 -translated.nds". In this case, you'll want to rename "For No$GBA.sav" to "FE12 -translated.sav". Then put that file in the "Battery" folder.
      The patched rom "FE12 -translated.nds" doesn't need to be in the "Battery" folder, although it can be. Just put it somewhere you can find it. NO$GBA provides a "Rom" folder, although you don't have to use it.
      The important thing here is the extension ".sav" or ".nds". The Battery save is the ".sav", while the rom is ".nds". Thus, even if the two files have the same name (which they need to) and are in the same folder (which they do NOT need to, but can be), they can both exist because they have different extensions, so your computer won't ask you to replace anything.
      Hope that helps. ^_^

      Delete
    2. Also, just an add on to Turtles explanation, if you've started up the game on your emulator prior to doing this, there will be a file called, "E12-translated.sav" in the battery folder already, and you do want to replace this one, otherwise when FE12 starts up it will draw save data from the original file rather than the file with bonus content.

      Delete
  56. Yahoo! Bought a copy of the game just so I could play this patch with a clear conscience. No regrets :)! Thanks for the hard work guys.

    ReplyDelete
  57. Thank you very much for the amazing work. Finally, one more great game westerns will be able to play.

    People who plan to use a R4 sdhc (or any clone) must've seen someone post a link to an update for TTMenu. But in case you only ever used the normal r4 kernel, you'll need the actual TTMenu first(which is specific). Search in google for "RetroGameFan Multi Cart Update v6.82" and get the files from the clones folder. After that download the files from the link in the comments below and put every dat file in the TTMenu folder. Done! (if it still doesn't work, backup your files and format your memory stick, that usually does the trick).

    ReplyDelete
    Replies
    1. Thanks, this solved it for me! I just copied the dat files in there instead of trying to fiddle around with TTdT, and it worked now! Thanks again!

      Delete
  58. Thank you sooo much Ogogin! It works!!!

    ReplyDelete
  59. So I am patching on Windows and using DeSmune. I am attemtping to patch by dragging the Rom onto the program, but when I do that, it says "This application has failed to start because MSVCR100.dll was not found. RE-installing the application may fix this problem" Then it says xdelta.exe has stopped working..but it proceeds to say the thing was patched and another copy was made, which is not the case, only the japanese unmodified rom exhists. what do i do?

    ReplyDelete
    Replies
    1. There is a separate post on the website by TheEnd that covers this.

      Delete
  60. Hi, I have a problem with my patch. Because when I use the emulator (Desmume), the game is not here. I tried to open the patch with the xdelda and "drag clean from here" and that's doesn't work. I use windows 7.

    ReplyDelete
  61. Hey, when I try to patch the file, it pops up a window that says "Compressing" but when it is done, nothing happens. Im dragging it over the "DRAG CLEAN ROM HERE" file. Help?

    ReplyDelete
  62. This comment has been removed by the author.

    ReplyDelete
  63. Uh didn't know img tags didn't work, after 6x getting Caesar (you guys probably know already) Marth says I'd like you hire you and Radd, should be to I'm guessing. Loving the game though and it's the first "bug or whatever" I've found.

    ReplyDelete
    Replies
    1. I think Caesar speaks for Radd so by hiring him you hire Radd.

      Delete
    2. this I know I told them of a typo bud.

      Delete
  64. I love you guys, please have my babies.

    ReplyDelete
  65. I love you so much.

    ReplyDelete
  66. I'm trying to play it on DeSmuMe but it freezes as soon as I hit "New Game". The music keeps going but everything else freezes

    ReplyDelete
    Replies
    1. Update DeSmuMe, if it isn't already updated to the latest one.

      Delete
  67. Thanks for your hard work and your wonderful job :)
    I'm using a debian OS (xubuntu), there's a way to patch the game via ubuntu?

    ReplyDelete